(Section in development!)

General

Please namespace your plugins as:

namespace {yourname}\agilepress\{your-plugin-name};

Consider naming your functions as follows:

function apxx_my_function_name() {
    /* ... your code ... */
}

…where the “xx” above is the initials of your plugin.  For example, if your plugin is “My Awesome AgilePress Add-on”[note]We have dibs on this name already, sorry.[/note] and the plugin filename is “my-awesome-agilepress-addon,” then the above function should be named “apmaapa_my_function_name.”  Make sense?

Activation and Deactivation Hooks

(tba)

Activation

(tba)

function apxx_activation_hook() {
    /* your AP activation code here */
}
add_action('agilepress_on_activation', __NAMESPACE__ . '\\apxx_activation_hook', 10, 0);

(tba)

Deactivation

(tba)

function apxx_deactivation_hook() {
    /* your AP deactivation code here */
}
add_action('agilepress_on_deactivation', __NAMESPACE__ . '\\apxx_deactivation_hook', 10, 0);

(tba)

Copyright 2017-2019, KMD Enterprises, LLC